返回顶部
开启左侧

[通达信] 天德上宝专用MACD重心买卖副图指标

[复制链接]
股票大数据 初来首发 显示全部楼层 发表于 2021-3-16 02:17:05 |阅读模式 打印 上一主题 下一主题
天德上宝专用MACD重心买卖副图指标 源码 贴图

{日MACD}
VOL1:=6;
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
OBV2:=EMA(OBV1,3)-MA(OBV1,9);
OBV3:=EMA(IF(OBV2>0,OBV2,0),3);
MAC3:=MA(C,3);
SHORT:=11;LONG:=21;MID:=7;
DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG)COLORWHITE;
DEA:EMA(DIF,MID)COLORYELLOW;
MACDDIF-DEA)*2,NODRAW;
STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,MACD,0.1,0),COLORRED;
吸:=XLPL.NOTEXT吸;
拉:=XLPL.NOTEXT拉;
派:=XLPL.NOTEXT派;
落:=XLPL.NOTEXT落;
STICKLINE(吸,0,MACD,0.1,0),COLORRED;
STICKLINE(拉,0,MACD,0.1,0),COLORRED;
STICKLINE(派,0,MACD,0,0),COLORGREEN;
STICKLINE(落,0,MACD,0,0),COLORGREEN;
主力买1:IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORRED;
主力买2:IF(DIF<ref(dif,1),dif,drawnull),color00ff00;[ size][="" font][="" color]


{资金博弈今日持仓}
超B:=L2_AMO(0,2)/10000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=L2_AMO(0,3)/10000.0;
大S:=L2_AMO(1,3)/10000.0;
中S:=L2_AMO(2,3)/10000.0;
小S:=L2_AMO(3,3)/10000.0;
TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);
总流入比:=(超B+大B+中B+小B)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW,COLORWHITE;
大单流入:=(超B+大B)/(超B+大B+超S+大S)*100,NODRAW,COLORWHITE;
大单流入限制:=IF((超B+大B+超S+大S)=0,0,大单流入);
成交总量:=(超B+大B+中B+小B+超S+大S+中S+小S),NODRAW,COLORWHITE;
机构参与度:=(超B+超S+大B+大S)/成交总量*100,NODRAW,COLORWHITE;
主买A:=ACTINVOL,COLORRED,NODRAW;
主卖A:=ACTOUTVOL,COLORGREEN,NODRAW;
主买C:=主买A*100/(主买A+主卖A),NODRAW,COLORRED;
{资金}
DRAWTEXT_FIX(1,0.2,0,0.01,STRCAT(STRCAT('资金流入比: ',CON2STR(总流入比,2)),' %')),COLORWHITE;
DRAWTEXT_FIX(1,0.4,0,0.01,STRCAT(STRCAT('大单流入比: ',CON2STR(大单流入限制,2)),' %买')),COLORWHITE;
DRAWTEXT_FIX(1,0.6,0,0.01,STRCAT(STRCAT('机构参与度: ',CON2STR(机构参与度,2)),' %')),COLORWHITE;
DRAWTEXT_FIX(1,0.8,0,0.01,STRCAT(STRCAT('主动买卖比: ',CON2STR(主买C,2)),' %')),COLORWHITE;

{------------------------------------------------------------------}
{重心}
A1:=(CLOSE*2+HIGH+LOW)/4;
A2:=EMA(A1,13)-EMA(A1,34);
A3:=EMA(A2,5);
重心:2*(A2-A3)*3.8,NODRAW;
J:=重心;
{MACD}
DIF1:=EMA(CLOSE,11) - EMA(CLOSE,21);
DEA1:=EMA(DIF1,7);
MACD1:=2*(DIF1-DEA1);
{KDJ}

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,NODRAW;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J1:=3*K-2*D;
{CII}
TYP:=(HIGH + LOW + CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
买:=CROSS(CCI,-100),NODRAW;
{RSI}
LC:=REF(CLOSE,1);
RSI2:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100,NODRAW;
R6:=(SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100),NODRAW;
MR持股:=K>D AND K>REF(K,1) AND DIF1>DEA1 AND DIF1>REF(DIF1,1) AND R6>50 AND R6>REF(R6,1) AND C>BBI AND BBI>REF(BBI,1),NODRAW;
IF(MR持股,J/3,DRAWNULL),COLORMAGENTA,LINETHICK2;

{买点}
负100买点:K>D AND K>REF(K,1) AND DIF1>DEA1 AND DIF1>REF(DIF1,1) AND R6>50 AND R6>REF(R6,1)AND 买 AND 重心>REF(重心,1),NODRAW;
M交叉临界:=351/28*(EMA(DIF1,9)-11/13*EMA(C,12)+25/27*EMA(C,26)),NODRAW;
K交叉点:=(3*REF(D,1)-2*REF(K,1))/100*(HHV(H,9)-LLV(L,9))+LLV(L,9),NODRAW;
长线持股:=K>D AND DIF1>DEA1 AND R6>50 AND C>BBI,NODRAW;
IF(长线持股,J/2,DRAWNULL)COLOR9966FF,LINETHICK1;

20213158352977738.png
游客,如果您要查看本帖隐藏内容请回复

精彩评论3

chaoran 首发新人 显示全部楼层 发表于 2021-4-6 15:45:57
楼主辛苦了

易道沟通 捐助会员 显示全部楼层 发表于 2021-4-16 06:06:02
感谢感动首发之家分享
我爱法_ZwWZc 首发新人 显示全部楼层 发表于 2021-4-25 10:17:57

用用试试看
您需要登录后才可以回帖 登录 | 立即注册 用百度帐号登录

本版积分规则

首发之家社区成立于2011年3月,内容涉及3C家电、数码生活智能电视,股票软件,4K,体育,软件,教育,游戏等资源指标公式论坛。
  • 官方手机版

  • 抖音号

  • 商务合作